Статус темы:
Закрыта.
  1. Cartel67 Пользователь

    Регистрация:
    29.04.16
    Сообщения:
    99
    Симпатии:
    12
    Пол:
    Мужской
    VKcom:
    id48727254
    Skype:
    cartelcomm
    Добрый день,думаю многим пригодится данная тема(вижу что её ещё нет) я задумался о переходе с 1.8.2 на 1.8.3 (хочу колор чат +Ваня похоже скоро будет только для него и писать и много ещё почему перечислять не буду) так вот как я понимаю плагины не предназначенные для 1.8.3 не будут на нем работать(или будут не корректно) как понимаю чтоб плагин нормально функционировал на 1.8.3( если он делался для 1.8.2) нужно в исходнике убрать инклуд колор чата,и заменить строчки client print color.(точно не знаю)
    Поэтому прошу скриптеров написать инструкцию как перейти на 1.8.3 и оставить при этом свои плагины.
    Зараннее спасибо)
     
    Andreyka :D нравится это.
  2. maFFyoZZyk Черный Жнец ^_^ Команда форума

    Регистрация:
    14.01.16
    Сообщения:
    1.238
    Симпатии:
    544
    Пол:
    Мужской
    Ну не обязательно все менять, можно просто перекомпилировать все плагины компилятором 1.8.3 с вашими инулюдами
    --- добавлено 29.05.16 ---
    Другое дело что они не нужны
     
    Cartel67 нравится это.
  3. Cartel67 Пользователь

    Регистрация:
    29.04.16
    Сообщения:
    99
    Симпатии:
    12
    Пол:
    Мужской
    VKcom:
    id48727254
    Skype:
    cartelcomm
    т,е я могу любой плагин перекомпилировать компирятором 1,8,3 ничего не меняя и поставить его на сервер с amxmod 1.8.3 и все будет работать(с цветным чатом как ибыло)?
    --- добавлено 29.05.16 ---
    Или могу убрать include так как он не нужен а все остальное оставить как есть и цветные сообщения все равно будут
     
  4. maFFyoZZyk Черный Жнец ^_^ Команда форума

    Регистрация:
    14.01.16
    Сообщения:
    1.238
    Симпатии:
    544
    Пол:
    Мужской
    Да, но не все
    И получишь кучу ошибок
    --- добавлено 29.05.16 ---
    Чтобы переделать удалением инулюда не отделаешься, зависит от того какой у тебя колор был ранее. Если от aghl то да, замени только chatcolor на client_print_color, если нет то надо еще переменные заменять
     
  5. Cartel67 Пользователь

    Регистрация:
    29.04.16
    Сообщения:
    99
    Симпатии:
    12
    Пол:
    Мужской
    VKcom:
    id48727254
    Skype:
    cartelcomm
    1.какие не смогу к примеру(имею ввиду почему)
    2.как быть если в лэнге или в исходнике !n.!t.!g нужно ли их менять на ^1 - ^4
     
  6. maFFyoZZyk Черный Жнец ^_^ Команда форума

    Регистрация:
    14.01.16
    Сообщения:
    1.238
    Симпатии:
    544
    Пол:
    Мужской
    Если client_print_color будешь ставить то да, надо менять

    А по поводу плагинов есть много нюансов,
     
  7. Cartel67 Пользователь

    Регистрация:
    29.04.16
    Сообщения:
    99
    Симпатии:
    12
    Пол:
    Мужской
    VKcom:
    id48727254
    Skype:
    cartelcomm
    спасибо я понял))
    Вопрос решен! Тему можно закрывать.
     
Статус темы:
Закрыта.